"just upgrade lol"

I hear it far too often. Developer cuts off a huge range of platforms by requiring some new fancy library. Users of old platforms complain. Developer responds with something along the lines of "just upgrade lol". Users get even more mad. Developer continues.

The simple truth is that this is needlessly reductive and completely disregards that older versions of distributions and operating system often have much merit to be used.

This article is WIP, please check back later for updates.